What's New

What You Need to Know About the Heartbleed Bug

The news is buzzing about a security vulnerability in OpenSSL, a popular, open-source protocol used by many websites that need to transmit secure data. Simply put, OpenSSL is an encryption technology that allows you to send personal and private information online.

Heartland Credit Union and affiliated vendors are in the process of completing a thorough review of online security in relation to the Heartlbleed bug. Current analysis and findings indicate that the Heartland website, Online Banking, Mobile Banking and affiliated programs, are not affected by this OpenSSL vulnerability.

Many major websites including Google, Facebook, Yahoo and Amazon have said they have taken steps to secure their sites and many others are likely aware of this issue and have been working to patch any servers they use with an updated version of OpenSSL that is not vulnerable to this exploit.

As a reminder, we highly recommend that you change your online passwords on a regular basis. You also shouldn’t use the same password for all the sites you access.

We work hard to protect your financial security and encourage you to monitor your accounts and notify us immediately at (651) 451-5160 or (800) 813-9185 if you identify unauthorized transactions.